Question

Volume not sized properly

Posted January 8, 2020 1.4k views
Block StorageDigitalOcean Accounts

I setup a 10GB block storage device. However after it mounted, it’s only been allocated 378MB. How can I fix that?

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Really sorry for the issue! Can you provide us the output of the following command:

df -h

This could possibly be the issue of the mount point of the Volume. We will need to resize2fs the partition of the Volume created.

Refer to below link, which provides you the insights on how to achieve this:

https://www.digitalocean.com/docs/volumes/how-to/increase-size/#resizing-a-partitioned-volume

Here is the output of df -h with the volume.

Filesystem                           Size  Used Avail Use% Mounted on
/dev/sda                             380M  370M     0 100% /mnt/volume_nyc1_01

  • Did you fix your problem?

    • This is a few months old, but my search brought my here first, before finding what I needed. So here it is a complete answer.

      It’s likely that the volume is unpartitioned. The link provided above is the correct resource, but you just needed to have the context that the drive is unpartitioned.

      If you’d like to review the steps:

      Or just do this:
      // Go here and copy the name of the volume.
      // It’ll be something like scsi0DOVolume_<volname>
      $ cd /dev/disk/by-id
      $ ls -al

      // resize2fs takes care of expansion.
      $ sudo resize2fs /dev/disk/by-id/scsi-0DOVolume<volname>

      // Verify
      $ df -h /dev/disk/by-id/scsi-0DOVolume<volname>