VPS Automatically shuts down my server - HELP PLEASE

  • Posted on February 10, 2015
  • DefconAsked by Defcon

So I’m hosting a private server on this VPS, which worked fine till about 3 weeks ago, everytime I try to run it now it says ‘running’ but after approx 5-10 seconds the VPS automatically shuts it down

Like I said there is nothing wrong with the server or whatsoever, so there must be a problem in the VPS, I’ll try to explain it once again with all details.

There are no errors, it shows Running, then it states that its up And after a few seconds it just goes back to the folder where it’s located ‘cd server’

I’m running a server on it, this server is located in the map cd server, there is a launcher which I can start by the code ‘Java -classpath bin:lib/* false false true’ As you see on my console it does run it, but my VPS stops running the launcher and just returns to the ‘cd server’ map where it’s located. I suspect there is somekind of action that makes it so the Launcher stops running for whatever reason, I’ve tried multiple servers, they all run fine on my PC and a few weeks ago I did not have this problem as they all ran fine on my VPS, now they stop running in a matter of minutes/seconds.

Please help error.png

Thats a photo of how my console looks.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @ryanpq:

I see. The first thing to check if you have a service crashing is that it is not exhausting the available memory. While your server is running try either opening a second ssh connection or opening the web console and running:

free -m

This will show an overview of your used and available memory. If your available memory is very low you will want to consider taking steps to resolve this. Here are a few options:

1.) Add a swap file to your droplet. This will be used when your physical memory runs low to prevent services crashing but is slower than physical ram.

2.) Upgrade to a larger droplet with more available memory.

3.) Check if your Runescape server configuration includes an option to limit memory use or otherwise optimize the service.

I would also recommend using screen when running your server. This will allow you to launch the service and leave it running in the background while you are still able to interact with your droplet. Our tutorial on running a Minecraft Server should provide a good example on how to do this.

View the original comment