Question

VPS nging - wordpress rich permlinks not working

  • Posted October 8, 2015
  • Nginx

I have VPS with nginx and have some subdomains there. Mostly Wordpress website and one Magento. Magento website is working fine but wordpress cant use rich permlinks. I am getting Server error. Can you please tell me what configuration file to use?

This is my file in etc/nginx/sites-enabled/wordpress

server {
    listen 80;

    server_name qbfweb.com;
    root /var/www/qbfweb.com;

    ## rewrite example.com to www.example.com
    if ($http_host != "qbfweb.com") {
        rewrite ^ $scheme://qbfweb.com$request_uri permanent;
    }

    location / {
        index index.html index.php; ## Allow a static html file to be shown first
        try_files $uri $uri/ @handler; ## If missing pass the URI to Magento's front handler
        expires 30d; ## Assume all files are cachable
    }

    ## Locations should be hidden
    location /app/                { deny all; }
    location /includes/           { deny all; }
    location /lib/                { deny all; }
    location /media/downloadable/ { deny all; }
    location /pkginfo/            { deny all; }
    location /report/config.xml   { deny all; }
    location /var/                { deny all; }

    location /var/export/ { ## Allow admins only to view export folder
        auth_basic           "Restricted"; ## Message shown in login window
        auth_basic_user_file /var/www/.htpasswd; ## See /etc/nginx/htpassword
        autoindex            on;
    }

    ## Disable .htaccess and other hidden files
    location ~ /\. {
        deny all;
        access_log off;
        log_not_found off;
    }

    location @handler { ## Magento uses a common front handler
        rewrite / /index.php;
    }

    location ~ .php/ { ## Forward paths like /js/index.php/x.js to relevant handler
        rewrite ^(.*.php)/ $1 last;
    }
    location ~ .php$ { ## Execute PHP scripts
        if (!-e $request_filename) { rewrite / /index.php last; } ## Catch 404s that try_files miss

        expires        off; ## Do not cache dynamic content
        fastcgi_pass   127.0.0.1:9000;
        fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
        fastcgi_param  MAGE_RUN_CODE default; ## Store code is defined in administration > Configuration > Manage Stores
        fastcgi_param  MAGE_RUN_TYPE store;
        include        fastcgi_params; ## See /etc/nginx/fastcgi_params
    }
}


Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

anybody what configuration file i have to use ? i tried many of them . thx

you can see here : http://qbfweb.com/dimensions/opening-hours/

500 Internal Server Error nginx/1.6.2

What is the Error you are getting?.