Question

VSFTP File Transfer Failed, Error 451

Command: STOR phase1.php Response: 150 Ok to send data. Response: 451 Failure writing to local file. Error: File transfer failed

I’m using FileZilla, and had no issues without using SFTP for the last several days. After performing consecutive uploads with bug fixes it gives me the error above. I have no idea what to do anymore.

I’ve the done following:

  • sudo chown -R ftp:ftp /var/www
  • restarted vsftpd and apache2
  • sudo chmod 777 -R /var/www
  • and reinstalled the LAMP stack

Nothing seems to be working and it was working just fine prior to last night. I’ve been doing socket connections for a project and thought maybe I exceeded the max connections so I reset the box, and my PC. Nothing changed.

I’m at a loss and would appreciate any help.

Note: It was working fine for 5 days up until last night. I don’t need suggestions to use SFTP, I don’t want to right now.

Thanks.

Subscribe
Share

Also whenever I go to my DigitalOcean Droplet panel it keeps refreshing saying “Something went wrong…” and refreshing the page. Can’t do anything right now, and it’s extremely frustrating.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Solved the 451 issue. Log file in /var/log/apache2 was 28 GB in size, deleted, problem solved.

Hi @derekrynd

The problem on the control panel is currently being investigated: https://twitter.com/digitalocean/status/857315015308824578

VSFTP should log to somewhere - perhaps /var/log/vsftp.log - have a look in the log to see if it will give you more information.