Question

W3 total cache error

  • Posted April 17, 2014

I have installed wordpress using this guide https://www.digitalocean.com/community/articles/how-to-install-wordpress-with-nginx-on-ubuntu-12-04

Now site working fine but I am facing errors when I try to install W3 total cache.


I get the following error:

FTP credentials don’t allow to write to file /var/www/nginx.conf

W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.

Please execute commands manually

or use FTP form to allow W3 Total Cache make it automatically.


I have installed FTP using this guide

https://www.digitalocean.com/community/articles/how-to-set-up-vsftpd-on-ubuntu-12-04 thanks


Please help.I am confused

Subscribe
Share

This comment has been deleted


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Try using ‘easyengine’, it will automate the process of installing and configuring Nginx + PHP-FPM + MySQL + Postfix + WordPress + W3TC + many more options <br>https://rtcamp.com/easyengine/docs/commands/site/create/

.htaccess File Permission Error Due to the security plugins, other plugins lost their writing permission to .htaccess and other files. The solution is simple.

  1. Check the directory permission level is 755 (in case WordPress installed in the directory).
  2. Now check the file permission for .htaccess which is necessary to be 644. Otherwise, you will encounter the error.

Source: DoubtSolver

@ajinkyathete: Once you update it, make sure you change its ownership back to root: <pre>sudo chown root /var/www/nginx.conf</pre>.

How to know if php-fpm has write access? I used this commands. <br> <br>$ sudo touch /var/www/nginx.conf <br>$ sudo chown www-data /var/www/nginx.conf <br> <br>Anyways when I change w3 settings everything is working fine. <br> <br>So, should I consider everything is successful.

it gets written to when you update or save w3 settings, assuming php-fpm has write access to it.

Really Thanks man. <br>I guess its working.W3 total cache not showing any errors. <br>However when I open /var/www/nginx.conf this file shows blank. <br>What should I edit in this file? Do I need to add something? <br>And at last should I restart nginx? <br>

you were suppose to create /var/www/nginx.conf like I said in my first message

Now Nginx is running when I removed the line include /var/www/nginx.conf ; <br> <br>

I did as you said. After that no changes occured so I thought of restarting nginx and I got this error <br> <br> sudo service nginx restart <br>Restarting nginx: nginx: [emerg] open() “/var/www/nginx.conf” failed (2: No such file or directory) in /etc/nginx/sites-enabled/wordpress:66 <br>nginx: configuration file /etc/nginx/nginx.conf test failed <br> <br>Now whole site is down. <br> <br>Oops! Google Chrome could not connect to <br> <br>Please help

sudo apt-get remove vsftpd <br> <br>you need to include /var/www/nginx.conf inside your server block in /etc/nginx/sites-enabled/wordpress <br> <br>sudo nano /etc/nginx/sites-available/wordpress <br> <br>after the <br> <br>location ~ .php$ { <br>… <br>} <br> <br>block, add a line <br> <br>include /var/www/nginx.conf ; <br> <br>then there should be your closing server brace already in the file <br> <br>} <br> <br>