Question

warning: error cloning submodules: entry not found

I have deployed “APP” in Digital Ocean.

I followed the steps mentioned in https://www.digitalocean.com/community/questions/how-can-use-submodules-in-private-repos-with-gitlab-in-do-apps to add Git Submodule.

At root of the project, I have .gitmodules which contains

[submodule "src/helper/joiyyyyy"]
	path = src/helper/joiyyyyy
	url = git@gitlab.com:adarshyyyy/joiyyyyy.git

Note: Instead of https:// I am using git@gitlab

Also, I have enabled the Deploy Key in Git Sub Module on GitLab.

Still when deploying, I am getting warning

[joiyyyy] [2021-09-10 05:14:38] => Initializing build
[joiyyyy] [2021-09-10 05:14:38] => Retrieving source code to /workspace
[joiyyyy] [2021-09-10 05:14:38] => Selecting branch "prod"
[joiyyyy] [2021-09-10 05:14:42] => Checking out commit "4720ab4de3f8bfbefe37b0d02fc22c0e14cbcdad"
[joiyyyy] [2021-09-10 05:14:43] => Cloning submodules
[joiyyyy] [2021-09-10 05:14:43]    warning: error cloning submodules: entry not found
[joiyyyy] [2021-09-10 05:14:43] => Got source_dir: /
[joiyyyy] [2021-09-10 05:14:43] => Using workspace root /workspace

Note: 3rd last line warning: error cloning submodules: entry not found.

Finally, the Deployment will fail, as Node is not able to import function from this Git Submodule.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hey there!

Gitlab submodules are kind of a tricky setup in app platform right now.

For a bit more information on how to get those workings please see: Submodules Gitlab

Hope it helps! Nate