Website doesn't load with www?

July 16, 2015 38.8k views
DNS

Believe me, I checked out the other questions and they didn't help me. My website is fitfrek.com and it doesn't load up if I place the www.

Similarly with another domain I have, survivelikeaboss.com It just goes back to the ip address in the domain bar. It could be the same problem...ANY help would be appreciated! Thanks!

8 comments
  • Actually, I tried to visit both fitfrek.com and www.fitfrek.com. The second one just seems to redirect the user to the non-www website. Is that the issue? I don't see any other problem.
    survivelikeaboss.com works perfectly, as far as I can see...

  • thanks for your comment. Suddenly seems to work fine now. Not sure why. It's fine if it redirects, as long as it works right?

    Survivelikeaboss keeps redirecting to the IP address which is just plain embarrassing lol. Click on anything on the page and it'll go back to the IP, and it doesn't work with www. Why is that? thanks for your quick response

  • You're right... survivelikeaboss resolves to an ip address no matter what link you click from within the site. Did you set your DNS records correctly, and in your server block did you enter your domain as the server or did you enter your IP address? First time I created a site, I entered the IP address of my droplet and that's what happened, my site displayed the IP address instead of my domain name. I might not have suggested anything helpful here, but it's somewhere to look and maybe something you could at least rule out.

    Good luck!

  • Hey!
    I already answered a similar question some months ago.
    It's probably not a DNS problem as @newhosting2015 says: as you can see, your links point to the IP in that way:

    <a href="http://IP_ADDRESS/2015/07/16/thisisapost/" title="thisisapost">thisisapost</a>
    

    Actually, you just have to tell Wordpress to use survivelikeaboss.com instead of the IP.
    I do not use Wordpress => I can't help you in this step, but I'm sure that is a very simple task!

    Have a nice day,
    Alfio.

  • I can't even go to the admin page to login anymore. Any idea what I can do from my droplet? This is so frustrating. Thanks for your help tho

  • Hey, @nqudimat.
    Can you please describe what goes wrong while trying to access the control panel?
    Anyway, you can manually edit the wp-config.php file from the terminal. Look at this official Wordpress tutorial for further information.

    Have a nice day,
    Alfio.

  • Thanks again missagliafio, it leads me to: http://104.236.75.165/wp-login.php?redirect_to=http%3A%2F%2Fsurvivelikeaboss.com%2Fwp-admin%2F&reauth=1 when Itry to get to the WP-admin. I'll try out that tutorial...

  • This is probably due to those conflicts between the IP website and the domain one.
    Editing the configuration file manually will probably solve everything.

    Bye, Alfio.

3 Answers

This question was answered by @missaglialfio:

Hey, @nqudimat.
Can you please describe what goes wrong while trying to access the control panel?
Anyway, you can manually edit the wp-config.php file from the terminal. Look at this official Wordpress tutorial for further information.

Have a nice day,
Alfio.

View the original comment

Hello,

I am very new to managing these things. I have just created my droplet for the wordpress, and I am having similar issues too. But I created two A records
1. Hostname @
2.Hostname www
So after creating these two records, I can find my website now when I type it with or without the www.
But my issue is when I type https:// nothing shows for my website. Someone told me about a wordpress plug-in called "wps hide login" its supposed to help as well. I haven't tried this yet though. Im nervous because the last time, I went into wordpress settings and changed my IP address to my URL, : 0 lol, I was unable to access my site and finally just had to rebuild it.
PS. Google Drive or Updraft Plus are good tools to keep back-ups or your wordpress sites, when you have to destroy or rebuild your droplets.

I am very new, so please excuse me if you find my answer unhelpful. I had similar issue I added in my DNS records: Hostname @
Hostname www
And mines started showing for me. But my issue was https:// not rendering and a support person notified me that my firewall was blocking port 443. Maybe you can check your firewalls.
Lastly, another person suggested to me a wildcard cname or A record. But because I am using wordpress i'm going to try a plug-in to hide my admin log-in area. So when I finally do try somethings, I wont lose access to my wordpress again lol
Ps. let me know what ends up working for, just in case I am still having issues too. I wish you the best in finding your solution

Have another answer? Share your knowledge.