Question

Website extremely slow/doesn't load in China

  • Posted June 6, 2014

My website (1gb) runs amazingly well in USA and Europe. I’ve currently in China and I noticed that either my website doesn’t load at all or is extremely slow. Any suggestions on how to fix this? Do I need to set up a server physically located in China?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This issue is related to the Chinese Firewall. The only solution I’ve found is to set up an instance with a provider on Main Land China.

i have the exact same problem and my droplet in Singapore works sporadically. It seems that my ip is blocked by China firewall and I have to use VPN to connect many times. I use a cn domain though, I am not sure if its because I don’t have an ICP. Does anyone know?

DO really need to have a China datacenter like Amazon does now.

well singapore is ALOT closer to China than both US and EU <br>come on irc and talk with us :) <br>http://webchat.freenode.net/?channels=digitalocean&uio=d4

I’m in US (ny2 region). Would a Singapore droplet really make a difference? <br> <br>What would the caching system be?

where is your droplet? US, EU or Singapore? <br>did you try moving it to singapore? or use some kind of caching system