Question

Website not working

  • Posted March 7, 2020
  • PHP

Can someone help me , please? I have an application in PHP 7.1 / CodeIgniter Framework. It was working in other hosting here in Brazil, but when upload to DO, it has stopped. when I try http (http://oneclickpy.com), there’s an error when I try https (https://oneclickpy.com), other error. I installed SSL certificate correctly, PHP version is the same than the other hosting, but I cannot make it work. Actually, the website seems to work, but the homepage is just blank.

Whats should I do? (php errors are enabled, the error_log file has nothing)

Subscribe
Share

Are you using a DO Marketplace deployment or just a droplet you have setup on your own?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Problem solved. My logs folder didn’t had the permissions os writing. Changed and solved my problem reading the errors. Thanks for the help!

Hi, @alexdo ! The application and system folders are set correctly. All the permissions are 755. Seems my system is working, cause when I change some data, like the access to database, I get an error. Phpmyadmin page also works normally. But when I set the correct database, and try to open the website, just a blank page. No PHP errors. Just a 500 error.

Hello, @rickfontoura

Have you checked the file/folder permissions and also if the application and system folders exist? You can check them in the index.php file:

$system_path = 'system';
$application_folder = 'application';

Check that the path to those is matching/correct.

Hope this helps!

Regards, Alex