Can someone help me , please?
I have an application in PHP 7.1 / CodeIgniter Framework.
It was working in other hosting here in Brazil, but when upload to DO, it has stopped.
when I try http (http://oneclickpy.com), there’s an error
when I try https (https://oneclickpy.com), other error.
I installed SSL certificate correctly, PHP version is the same than the other hosting, but I cannot make it work. Actually, the website seems to work, but the homepage is just blank.

Whats should I do?
(php errors are enabled, the error_log file has nothing)

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Hello, @rickfontoura

Have you checked the file/folder permissions and also if the application and system folders exist? You can check them in the index.php file:

$system_path = 'system';

$application_folder = 'application';

Check that the path to those is matching/correct.

Hope this helps!

Regards,
Alex

Hi, @alexdo !
The application and system folders are set correctly.
All the permissions are 755.
Seems my system is working, cause when I change some data, like the access to database, I get an error. Phpmyadmin page also works normally.
But when I set the correct database, and try to open the website, just a blank page. No PHP errors. Just a 500 error.

  • Hello, @rickfontoura

    Are there any logged errors in the browser’s console? You can press F12 and check the Console tab for any logged errors. Also can you check if the error reporting is turned on?

    You can use a ini_set in order to do this:

    ini_set('display_errors', 1);
    

    Let me know how it goes.

    Regards,
    Alex

    • Already done this…
      No errors in error_log neither in browser.
      Just a Blank page with 500 internal server error :(

    • new information…
      When I try access:
      http://oneclickpy.com/admin
      It works
      But after logged in, the adress http://oneclickpy.com/admin/painel
      just the same blank bage :(

      My project is like this: in the controller and views folders, I have the files normally, and a folder named “admin” to the system panel.
      My .htaccess is this:
      RewriteEngine On
      RewriteBase /
      RewriteCond %{REQUESTFILENAME} !-f
      RewriteCond %{REQUEST
      FILENAME} !-d
      RewriteCond $1 !^(index.php|assets|upload|robots.txt|..css)
      RewriteRule ^(.
      )$ index.php?/$1 [L]

      It was working fine in other hosting. But in DO nothing.

Problem solved. My logs folder didn’t had the permissions os writing. Changed and solved my problem reading the errors. Thanks for the help!

  • I’m glad you’ve sorted this. Also thanks for sharing what the issue was as other users may find this useful if they run into the same problem.

    Regards,
    Alex

Submit an Answer