Question

Website uploaded to any folders other than var/www/html does not work

Posted April 23, 2019 822 views
UbuntuInitial Server Setup

Hi there,

I am new to DO and trying to upload my website to my Droplet.

I uploaded my website to root/srv/www/mywebsite/ and modified a file called:
etc/nginx//sites-available/default to use the folder I just created

So I removed

root /var/www/html;

Added

root /srv/www/mywebsite;

then I restart my nginx server, by using the following commands:

sudo service nginx restart
sudo systemctl reload nginx

But none of them worked.

Only when I changed back to use the /var/www/html inside default file, then the server starts to work.

Please help!

1 comment
  • If the folder ownership isn’t the issue, you may get some more information from testing the Nginx configuration prior to restarting the server:

    • sudo nginx -t

    In addition, your response implies you added another ‘root’ directive, whereas updating the existing root directive is what you probably wanted to do.

    As an aside, editing the primary server block is generally not the best approach. Completing Step 5 – Setting Up Server Blocks (Recommended) in this Nginx guide is the recommended method (and includes steps on permissions as jarland pointed out).

    by Justin Ellingwood
    by Kathleen Juell
    Nginx is one of the most popular web servers in the world and is responsible for hosting some of the largest and highest-traffic sites on the internet. It is more resource-friendly than Apache in most cases and can be used as a web server or reverse proxy. In this guide, we'll discuss how to get Nginx installed on your Ubuntu 18.04 server.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Greetings!

I’d have to know the error that Nginx is logging to know for sure, but I suspect that permissions may be related. Try this:

chown -R www-data. /srv

Then change the document root back, restart Nginx, see if you get a better result.

Jarland

Submit an Answer