Question

Welcome to nginx! after droplet backup restore (emergency)

My client has paid ads and visitors coming to their site and they’re going crazy, so I’m a little frustrated here.

http://www.signa.com

After restoring a droplet from when the site worked, I’m getting “Welcome to nginx!”

Following the instructions in this discussion: https://www.digitalocean.com/community/questions/website-only-show-welcome-to-nginx

I’m getting a 403 error

Nothing in: /var/log/nginx/error.log.1 /var/log/nginx/error.log

Inside /etc/nginx/sites-available/default (comments removed):

server {
        listen 80 default_server;
        listen [::]:80 default_server ipv6only=on;

        root /var/www/;
        index index.html index.htm;

        server_name localhost;

        location / {
               
                try_files $uri $uri/ =404;
             
        }


 location ~ /.well-known {
                allow all;
        }
}

— update as I’m troubleshooting —

I used this tutorial to set up my droplet with wordpress: https://www.digitalocean.com/community/tutorials/how-to-migrate-wordpress-from-shared-hosting-to-a-cloud-server-with-zero-downtime

I didn’t install nginx, I installed Apache. I’m not sure why it was running.

I’ve stoped nginx and restarted apache but I’m getting an error: /etc/init.d/apache2 restart

  • Restarting web server apache2 [fail]
  • The apache2 configtest failed. Output of config test was: AH00526: Syntax error on line 33 of /etc/apache2/sites-enabled/default-ssl.conf: SSLCertificateFile: file ‘/etc/letsencrypt/live/www.signa.com/cert.pem’ does not exist or is empty Action ‘configtest’ failed. The Apache error log may have more information.

/etc/letsencrypt/live/www.signa.com/cert.pem is not empty, there is a certificate inside I’ve just verified

Apache error logs (/var/log/apache2/error.log) only have logs from Yesterday, nothing from today

Subscribe
Share

default-ssl.conf:

<IfModule mod_ssl.c>
        <VirtualHost _default_:443>
                ServerAdmin webmaster@localhost
                ServerName signa.com
                ServerAlias www.signa.com
                DocumentRoot /var/www/

                ErrorLog ${APACHE_LOG_DIR}/error.log
                CustomLog ${APACHE_LOG_DIR}/access.log combined

                SSLEngine on

**line33** SSLCertificateFile      /etc/letsencrypt/live/www.signa.com/cert.pem
                SSLCertificateKeyFile /etc/letsencrypt/live/www.signa.com/privkey.pem

                
 <FilesMatch "\.(cgi|shtml|phtml|php)$">
                                SSLOptions +StdEnvVars
                </FilesMatch>
                <Directory /usr/lib/cgi-bin>
                                SSLOptions +StdEnvVars
                </Directory>

                BrowserMatch "MSIE [2-6]" \
                                nokeepalive ssl-unclean-shutdown \
                                downgrade-1.0 force-response-1.0
                
                BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown

SSLCertificateChainFile /etc/letsencrypt/live/www.signa.com/chain.pem
        </VirtualHost>
</IfModule>

File: /etc/apache2/httpd.conf

<VirtualHost _default_:443>
ServerName signa.com:443
SSLEngine on
SSLCertificateKeyFile /etc/apache2/ssl/signa.com.key
SSLCertificateFile /etc/apache2/ssl/signa.com.cert
ServerAdmin cling@jackrabbit.host
DocumentRoot /var/www
<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/errorSSL.log

LogLevel warn

CustomLog ${APACHE_LOG_DIR}/accessSSL.log combined

</VirtualHost>

File:/etc/apache2/apache2.conf

Mutex file:${APACHE_LOCK_DIR} default
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel warn
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf
Include ports.conf
<Directory />
        Options FollowSymLinks
        AllowOverride None
        Require all denied
</Directory>

<Directory /usr/share>
        AllowOverride None
        Require all granted
</Directory>

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>

AccessFileName .htaccess

<FilesMatch "^\.ht">
        Require all denied
</FilesMatch>

LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

IncludeOptional conf-enabled/*.conf

IncludeOptional sites-enabled/*.conf

Since nginx and isn’t your webserver and Apache is we need to see the apache config and the lines around line 33 to see if there are any syntax errors there.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I’ve restored the droplet once again to start over, this time I immediately stopped nginx and restarted apache as sudo. I wasn’t restarting apache as sudo which seems to have caused the permission error.