Question

wget "failed: Name or service not known" centos7

Posted December 23, 2021 190 views
CentOS

I have 3 droplets with DO (AMS3). Today, I faced a problem. It seems the servers could not connect to the outside world.

Here is what I tried:
wget google.com

Response:
–2021-12-23 15:53:47– http://google.com/
Resolving google.com (google.com)… failed: Name or service not known.
wget: unable to resolve host address ‘google.com’

I followed the steps mentioned on:
https://www.digitalocean.com/community/questions/wget-unable-to-resolve-host-address
And I received exactly the same responses “lauramoreno1436” reported:

cat /etc/resolv.conf
nameserver 67.207.67.2
nameserver 67.207.67.3

dig www.dropbox.com
; <<>> DiG 9.11.4-P2-RedHat-9.11.4-26.P2.el7_9.4 <<>> www.dropbox.com
;; global options: +cmd
;; connection timed out; no servers could be reached

dig @8.8.8.8 www.dropbox.com
; <<>> DiG 9.11.4-P2-RedHat-9.11.4-26.P2.el7_9.4 <<>> @8.8.8.8 www.dropbox.com
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached

I am using bizcloud.io to purchase DO droplets using cryptocurrency. I am not sure if I could open a ticket by DO.
Any help is appreciated.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hey there!

This sounds like it may be a DNS issue, but you would want to confirm by trying to ping an IP address. ping -c10 8.8.8.8 If you are able to reach that IP then there may be an issue with your resolvers. You could look at updating those to another set and then try the request again. If you aren’t able to ping the IP then you would probably want to reach out to bizcloud.io for them to check if there is network issue on the droplet itself.

Hope it helps!
Nate

  • Hi;
    Thanks for the update.
    I already tried to ping an IP address, but the ping also didn’t work.
    The problem is resolved by itself. I am not sure what the problem was and who resolved it. I searched all already published solutions on the web, but none of them helped.

    The problem persisted for ~10 hours.
    Iman.