Question

what to do if it didn't detect static site type?

Connected Tutorial
This question is a follow-up to this tutorial:

I have only one file index.html in my git repo. When I go to step 3 “Configure your app” there is no Static Site type selected. It shows the text that Static assets detected but in select there is no options. Is this a bug?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@npopov2527 👋

I tried to reproduce this with a repo that contains just an index.html file (https://github.com/snormore/sample-html), but it was detected as a Static Site component type during the create flow and deployed successfully: https://sample-html-g3yz2.ondigitalocean.app/

If your repo is public, and you can share it with me, then I can fork it and see if I can spot the problem from here. Otherwise, I’d suggest reaching out to DO Support so we can take a look at your app specifically.