subbuj9
By:
subbuj9

While Compiling the OSRM getting the error

November 29, 2016 36 views
DigitalOcean Ubuntu

While Compiling the OSRM getting the below error.

Followed below instructions.
How To Set Up an OSRM Server on Ubuntu 14.04

https://www.digitalocean.com/community/tutorials/how-to-set-up-an-osrm-server-on-ubuntu-14-04

-- Could NOT find Lua: Found unsuitable version "5.2.3", but required is exact version "5.2" (found /usr/lib/x8664-linux-gnu/liblua5.2.so;/usr/lib/x8664-linux-gnu/libm.so)
-- Could NOT find Lua: Found unsuitable version "5.2.3", but required is exact version "5.1" (found /usr/lib/x8664-linux-gnu/liblua5.2.so;/usr/lib/x8664-linux-gnu/libm.so)

Please check and suggest how to build OSRM

1 Answer

It looks like this is a known issue with OSRM being too strict in it's dependency checks. If you specify the 5.4.0 version when installing it should correct this.

Have another answer? Share your knowledge.