Why am i getting "Welcome to nginx! further configuration is required" when I type instead of just

So i am hosting two seperate domains on the same droplet by utlizing nginx and getting this error. Cant seem to figure out why as I have my other site set up identically and both and work fine.

When I run whois I get absolutely no results. Totally confused if someone could explain what is going on it would be much appreciated!


so when I run whois I get my DO name servers. when I run whois I get “no match” super confusing to me…


$TTL 1800 IN SOA 1446855892 10800 3600 604800 1800 1800 IN NS 1800 IN NS 1800 IN NS 1800 IN A 1800 IN CNAME

when you whois are you getting the digital ocean name servers? This would look like : Name Server: NS1.DIGITALOCEAN.COM Name Server: NS2.DIGITALOCEAN.COM Name Server: NS3.DIGITALOCEAN.COM

I think your having an issue with the proper name servers not being set up, or you don’t have the correct Cname or A record set up in your Digital ocean networking dashboard for that specific domain.

Im not an expert but I had that issue and worked through these few steps

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

server { listen 80;


location / {
    proxy_pass http://localhost:8080;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection 'upgrade';
    proxy_set_header Host $host;
    proxy_cache_bypass $http_upgrade;


this did not seem to fix the problem :(

Edit your domain conf Server;