Question

Why am I not able to run a mysql server on my debian droplet?

  • Posted December 8, 2013

When it asks me to input a new root password for the main mysql user, it says that it can’t set a password because a password is already set or because it can “contact the mysql server” and then when it’s supposed to start the server, it prompts the following error:

http://pastebin.com/35pCkkJk

Thank you in advance guys

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Do you, by chance, have any recent snapshots of your droplet? So you can simply spin up a new one (and destroy the damaged one)?

I’m not working on a fresh Debian install. My droplet’s main problem is that someone has been playing with permissions and that’s why it’s not working well, since some other applications give perms errors. <br> <br>I’ve already contacted DigitalOcean’s support but they told me that they can’t help me since they’re an unmannaged hosting service.

Are you working from a fresh install of Debian? Have you followed any tutorials up to this point? If so, which ones?

<br>invoke-rc.d: initscript mysql, action “start” failed. <br>dpkg: error processing mysql-server-5.5 (–configure): <br> subprocess installed post-installation script returned error exit status 1 <br>dpkg: dependency problems prevent configuration of mysql-server: <br> mysql-server depends on mysql-server-5.5; however: <br> Package mysql-server-5.5 is not configured yet. <br> <br>dpkg: error processing mysql-server (–configure): <br> dependency problems - leaving unconfigured <br>Errors were encountered while processing: <br> mysql-server-5.5 <br> mysql-server <br>E: Sub-process /usr/bin/dpkg returned an error code (1) <br>

Have you tried? <br><pre>sudo apt-get -y install mysql-server</pre>

When I run “apt-get install mysql-server” and it fails to run the new mysql server, on the process it outputed the following error: <br> <br> <br>131208 17:34:18 InnoDB: Using Linux native AIO <br>/usr/sbin/mysqld: Can’t create/write to file ‘/tmp/ibxGZpzM’ (Errcode: 13) <br>131208 17:34:18 InnoDB: Error: unable to create temporary file; errno: 13 <br> <br> <br>We have been having permissions problems, which aren’t solved yet, on our debian droplet. <br>Even with this error, I tried to run “mysql_install_db” but it’s giving the same error.

Have you check out the MySQL sections of either: <br> <br>1.) <a href=“https://www.digitalocean.com/community/articles/how-to-install-linux-nginx-mysql-php-lemp-stack-on-debian-7”>How To Install Linux, Nginx, MySQL, PHP (LEMP) Stack on Debian 7</a>; or <br> <br>2.) <a href=“https://www.digitalocean.com/community/articles/how-to-install-linux-apache-mysql-php-lamp-stack-on-debian”>How To Install Linux, Apache, MySQL, PHP (LAMP) stack on Debian</a>?