Why am I not able to run a mysql server on my debian droplet?

Posted December 8, 2013 4.1k views
When it asks me to input a new root password for the main mysql user, it says that it can't set a password because a password is already set or because it can "contact the mysql server" and then when it's supposed to start the server, it prompts the following error: Thank you in advance guys

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
7 answers
by Etel Sverdlov
This tutorial explains how to install Apache, how to install MySQL, how to change the root MySQL password, how to install PHP, and how to see what libraries are available. LAMP stack is a group of open source software used to get web servers up and running. The acronym stands for Linux, Apache ( the web server) , MySQL (the database), and PHP (the language). This tutorial is written for Debian.
When I run "apt-get install mysql-server" and it fails to run the new mysql server, on the process it outputed the following error:

131208 17:34:18 InnoDB: Using Linux native AIO
/usr/sbin/mysqld: Can't create/write to file '/tmp/ibxGZpzM' (Errcode: 13)
131208 17:34:18 InnoDB: Error: unable to create temporary file; errno: 13

We have been having permissions problems, which aren't solved yet, on our debian droplet.
Even with this error, I tried to run "mysql_install_db" but it's giving the same error.
Have you tried?
sudo apt-get -y install mysql-server

invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.5 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.5; however:
Package mysql-server-5.5 is not configured yet.

dpkg: error processing mysql-server (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
Are you working from a fresh install of Debian? Have you followed any tutorials up to this point? If so, which ones?
I'm not working on a fresh Debian install. My droplet's main problem is that someone has been playing with permissions and that's why it's not working well, since some other applications give perms errors.

I've already contacted DigitalOcean's support but they told me that they can't help me since they're an unmannaged hosting service.
Do you, by chance, have any recent snapshots of your droplet? So you can simply spin up a new one (and destroy the damaged one)?