Question

Why bundle install fails as killed

  • Posted February 16, 2014

I am trying to bundle install my droplet:

Ruby on Rails on Ubuntu 12.10 (Nginx + Unicorn)

Yet it always exits with killed. I’ve tried adding swap as mentioned here:

https://www.digitalocean.com/community/articles/how-to-add-swap-on-ubuntu-12-04

Has anyone else seen this and perhaps solved it?

Subscribe
Share

You can solve it by adding swap

@timsly Worked for me. Thanks!


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I just encountered the same problem. The root cause for the error is there is not enough free memory. If you do not want to add extra swap, take a look at the running processes and quit what you need to free up memory.

I just encountered the same problem. The root cause for the error is there is not enough free memory. If you do not want to add extra swap, take a look at the running processes and quit what you need to free up memory.

I just encountered the same problem. The root cause for the error is there is not enough free memory. If you do not want to add extra swap, take a look at the running processes and quit what you need to free up memory.

i have the same problem always show me Killed in bunlde install i try with 2 diferent proyect

having the same issue, had to restart bundle install a few times to deal with that.

I’m having the same issue and also looked into the suggestions for adding swap - I do not use the nokogiri gem, do you know what the issue was?

Nevermind, I think this was a specific issue with Nokogiri. Problem solved.