Question

Why can't i see the "permitrootlogin" section in my /etc/ssh/sshd_config file inside my ubuntu droplet

Please i am a new user and very new to cloud server management. i added ssh key to my root user, now i want to disable root login password. i loged in again as root user, typed nano /etc/ssh/sshd_config. the file opened in nano but i can’t find the line / section from where i can change the “permitrootlogin” settings. any help will be appreciated plz.

Subscribe
Share

Hello!

Have you modified /etc/ssh/sshd_config in any way since spinning up your Droplet? What’s the output of the following command (which searches for any occurrences of root in /etc/ssh/sshd_config)?

sudo grep -i root /etc/ssh/sshd_config

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

sudo grep -i root /etc/ssh/sshd_config

PermitRootLogin yes

the setting of "PermitRootLogin yes

when i write this “nano /etc/ssh/sshd_config” command then I get a warning [ Directory ‘etc/ssh’ does not exist ]

Be ware that there is a very similar looking file /etc/ssh/ssh_config (note there’s no d). You could potentially be looking in the wrong file.

Really? That’s pretty strange. It should be under # Logging section.

# Authentication:
LoginGraceTime 120
PermitRootLogin no