Question

Why can't login my VPS with SSH-console

My new VPS was set up with Singapore server farm yesterday. Today, my ssh connection got disconnected twice unintentionally in 3 hours. The worst of all, it got disconnected for 1 hour or so just now, showing

** connection time out (port:22)**

and I felt annoyed so that I destroy my server image(I thought it is my setup was causing problem) and try to rebuild the whole server

Nonetheless, when I started over with a new server image, and tried connecting it with (new ipaddress and also my ssh-public key), it still shows “connection time out”.

Although the whole time, I keep one of my console “ping xxx.xxx.xxx.xxx” to give me a clue about the networking status. It looks obvious that the ping response time is quite poor to your server, sometimes it interrupts. However, I could always browser your digitalocean User dashboard all the time.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

We have experienced this as well. .There seems to be something unstable in the setup somewhere.

We had a droplet with a user and the public and private key set up fine and PermitRootLogin set to no. We created another droplet from this one, reset the password, and weren’t able to login with that user. We created another user and public key but we weren’t able to login with the new users permissions. Somehow it allowed the old one. Once I switched off my mac, and switched it on again, can’t login to the server! Can’t login from the web console of DO. Anyone solved for this?

Works fine here, must be your internet connection / firewall.

MacBook-Air:~ Woet$ ssh 128.199.123.97
root@128.199.123.97's password:
Permission denied, please try again.
root@128.199.123.97's password:

Now it drops me again: 64 bytes from 128.199.123.97: icmp_seq=1351 ttl=46 time=204 ms 64 bytes from 128.199.123.97: icmp_seq=1352 ttl=46 time=1096 ms 64 bytes from 128.199.123.97: icmp_seq=1353 ttl=46 time=143 ms 64 bytes from 128.199.123.97: icmp_seq=1354 ttl=46 time=142 ms 64 bytes from 128.199.123.97: icmp_seq=1355 ttl=46 time=143 ms

(nothing had echoed 3 minutes earlier till now)