Question

Why can't start my vsftpd on debian?

dpkg -l vsftpd Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ||/ Name Version Architecture Description ++±==============-============-============-================================= ii vsftpd 2.3.5-3 amd64 lightweight, efficient FTP server

/etc/init.d/vsftpd start Starting FTP server: vsftpd. root@debian:/home/debian7# /etc/init.d/vsftpd status vsftpd is not running

netstat -nlap |grep .21|more tcp 0 1 192.168.1.100:45145 216.58.221.106:80 SYN_SENT
4704/firefox
tcp 0 1 192.168.1.100:45163 216.58.221.106:80 SYN_SENT
4704/firefox
tcp 0 1 192.168.1.100:45164 216.58.221.106:80 SYN_SENT
4704/firefox
tcp 0 1 192.168.1.100:45157 216.58.221.106:80 SYN_SENT
4704/firefox
tcp 0 1 192.168.1.100:42463 159.106.121.75:443 SYN_SENT
4704/firefox
tcp 0 1 192.168.1.100:45140 216.58.221.106:80 SYN_SENT
4704/firefox
tcp 0 1 192.168.1.100:45153 216.58.221.106:80 SYN_SENT
4704/firefox
tcp 0 0 192.168.1.100:44982 121.18.239.246:80 ESTABLISHED 4704/firefox
tcp 0 1 192.168.1.100:42468 159.106.121.75:443 SYN_SENT
4704/firefox
udp 0 0 0.0.0.0:821 0.0.0.0:*
1918/rpcbind
udp 0 0 0.0.0.0:41219 0.0.0.0:*
3283/avahi-daemon: udp6 0 0 :::821 :::*


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Enable logs in Your vsftpd config, than paste log here…

Config: syslog_enable=NO vsftpd_log_file=/var/log/vsftpd.log