Question

Why do I get a a NoSuchKey response for some files in a folder on Spaces sub-domain URL but it works on the origin URL?

For example, the Subdomain URL https://static.quantimo.do/img/Ionicons/png/512/ios-list-outline.png does not work. However, the origin URL https://qm-public.sfo2.digitaloceanspaces.com/img/Ionicons/png/512/ios-list-outline.png DOES work.

I’ve tried purging the CDN, clearing browser cache, etc.

This only happens for some of the files in that folder. For instance, the Subdomain URL https://static.quantimo.do/img/Ionicons/png/512/alert-circled.png DOES work.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thanks, Matt!

Yeah, I found out that Cloudflare was caching the Not Found response.

Disabling Cloudflare caching didn’t work but purging the Cloudflare cache fixed it.

Hi there @mikepsinn,

I have just tried the URL you are reporting as not working (https://static.quantimo.do/img/Ionicons/png/512/ios-list-outline.png) and it loads the image fine in my browser.

I imagine that this is some sort of caching issue on your end, from the information you’ve provided, I’d suggest trying a different browser as this is less likely to have anything cached and see if it then works for you.

Hope that helps! - Matt.