Question

Why do I get this "Could not reverse map the HTTPS VirtualHost to the original" message when I try to install an SSL?

Posted April 5, 2018 3.6k views
ApacheLAMP StackOne-Click Install AppsUbuntu 16.04

I’m trying to set up a vhosts file on my server with separate vhost txt files in it. Everything seems to work fine and I am able to reach both of the areas I try to set up using http. When I try to install an SSL cert however, it always comes up with a message telling me:

Could not reverse map the HTTPS VirtualHost to the original

IMPORTANT NOTES:
 - Unable to install the certificate
 - Congratulations! Your certificate and chain have been saved at:

I’ve tried reinstalling and restarting the droplet 3 times now and every time it is the same. I don’t know what I’m doing wrong I’m new to all this. Could someone help point me in the right direction?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
5 answers

To be honest, not really. Okay so I think you’re saying I need to include the bit from the default-ssl.conf file.

The only thing is that I thought that using

sudo certbot --apache -d example.com -d www.example.com

would add the bits I needed in the vhosts file and add the ssl version. I don’t understand why i can’t get this to work when I’ve seen it work before on other servers that I use.

Are you familiar with the apache2 sites available folder?

Installing a cert for apache2 involves setting up the virtual host listening on 443. It’s that config that needs to reference your certificate and chains and private key.

There are 2 default Apache 2 confs in sites available. One for clear port and one for ssl.

you should at first enable the ...ssl.conf one in sites-available (like sudo a2ensite my-ssl.conf) and inside that, put this: ServerName YOURDOMAIN.LTD

This happened to me, when i tried to setup (rewrite) old droplet domain with another. The problem was that in sites-enabled/mysite.com (or in other one, or in htaccess too) there was forced redirection from non-https to https version (using RewriteRule ^ .....) . So, while site is till not using HTTPS, that forced redirection makes the problem, comment those lines before your site has SSL.

The perfect template. Try this. Worked for me after days of looking for a solution.

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerName domain.com
    ServerAlias www.domain.com
    DocumentRoot /var/www/html

    <Directory /var/www/html/>
            Options FollowSymLinks
            AllowOverride All
            Require all granted
        </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
Submit an Answer