Question

Why I can't run a CS16 server on a 5$ droplet ?

Hello, I’m trying to run a cs16 server on 5$ droplets, but for some reason the when I start the game server, the socket does not get created. I’ve tried on other VPS providers and it does work. I’ve installed the cs16 server using linuxgsm. A couple a weeks ago it was working.

Thank you !

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

As you can see the server is started, but I cannot see any port being created.

(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN      -               
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      -               
tcp        0      0 127.0.0.1:8091          0.0.0.0:*               LISTEN      -               
tcp6       0      0 :::8086                 :::*                    LISTEN      -               
tcp6       0      0 :::22                   :::*                    LISTEN      -               
tcp6       0      0 :::8088                 :::*                    LISTEN      -               
udp        0      0 0.0.0.0:42335           0.0.0.0:*                           -               
udp        0      0 127.0.0.1:8096          0.0.0.0:*                           -               
bla@bla:~$ systemctl --user status csserver
● csserver.service - Counter Strike server
   Loaded: loaded (/home/bla/.config/systemd/user/csserver.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2020-09-29 12:23:50 CEST; 39min ago
  Process: 1358 ExecStop=/home/bla/gameserver/csserver stop (code=exited, status=0/SUCCESS)
  Process: 1960 ExecStart=/home/bla/gameserver/csserver start (code=exited, status=0/SUCCESS)
 Main PID: 2844 (tmux)
   CGroup: /user.slice/user-1000.slice/user@1000.service/csserver.service
           ├─2844 tmux new-session -d -x 80 -y 23 -s csserver ./hlds_run -game cstrike -strictportbind +ip 138.68.103.155 -port 27015 +clientport 27005 +map cs_assault +servercfgfile csserver.cfg -maxplayers 16
           ├─2845 /bin/sh ./hlds_run -game cstrike -strictportbind +ip 138.68.103.155 -port 27015 +clientport 27005 +map cs_assault +servercfgfile csserver.cfg -maxplayers 16
           ├─2866 cat
           └─2877 cat

Hi @bobocsabin,

Most probably there is an error behind the issue you are facing. Can you please check if you have enough space on the server and other common stuff like that?

If all of them are okay, can you check the application’s logs to see what’s going on? Most probably there is a valid reason behind this. These logs, should be somewhere in the /var/log/ folder.

Regards, KFSys