Why is Ghost not installing correctly?

October 2, 2018 975 views
Ghost

Okay so I already have a droplet dedicated to one Ghost blog. I wanted to create a test droplet today so I went ahead and used the one-click app to install Ghost with Ubuntu 18.04. I logged into the console once the droplet was created.

Ghost installer ran automatically up until the point where it notifies you of entering your domain and email for SSL. After pressing ENTER, the installer just exists and when I check /var/www/ghost/ the directory is empty. Am I doing something wrong here?

This I’ve tried:

  • Rebuilding the droplet
  • Destroying and recreating a droplet
  • Trying to install on a droplet in a different location
6 Answers

Same problem here. Ended up installing it on my own.

has this been fix yet? , having the same issue

  • The support says this is an issue related to the $5 droplet. Haven’t confirmed if its happening on higher tiers or not.

Still having same issue on 2019, really sucks…

Infuriating. Feel like I’m being “punked” trying to use this system. I’ve been trying for months. I RTFM and have followed directions in the docs to create a “one-click” Ghost. It’s just unusable, inexcusable. “One-click” is misused here.

Welll… bummerrrrrrrr..... it doesn’t work.... great. I was hoping to roll out a Ghost site in 1.2.3..... but nothing....

same here. tried the “click once” option and now stuck in hell.

can’t run any ghost commands because

Working directory is not a recognisable Ghost installation.
Run `ghost config` again within a folder where Ghost was installed with Ghost-CLI.

i figured out command needs to be run from /var/www/ghost but no matter what i do, i still get 502 Bad Geteway when i try to go to http://my_ip/ghost

Have another answer? Share your knowledge.