Question

Why is my server configuration inconsistent?

I got a domain in GoDaddy and I am using DigitalOcean (DO) to deploy my webapp. I created a ssl certificate using letsencrypt and aparently everything is fine. When I run the ssl-test from www.ssllabs.com it appears to be a problem with the server configuration (Warning: Inconsistent server configuration)

Why is my godaddy ip address not certified as my DO ip?

thx


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Yes, you can also delete the certificate in the acme-tiny directory and then issue another SSL certificate.

Let me know how it goes.

Alex

Thanks for replying back.

The DNS should be pointed correctly, usually you just need to point the A record of the domain name to the DigitalOcean IP address.

Two things to check:

  1. Make sure the SSL was issued for both www and non www version of your domain name.
  2. If you’re using nginx, make sure to check the config file and see if the domain is configured properly, because it should include both domains:
server_name yourdomain.com www.yourdomain.com;

Alex

Hi, Yes, I have two domains listed in the result in ssllabs.com. One is the IP address of DigitalOcean with A+ Grade, and the other address is the one in Godaddy with no grade. An additional message says “Certificate not valid for domain name”…

I am not sure about the pointing. What I have done is in godaddy create a new A record to root and the DO ip address…

I have also tried changing the nameservers but same result.

I suppose, I am doing the IP pointing wrong. Is the only thing I can think of.

Cheers