Question

Why is networking dead after a soft reboot?

Posted January 16, 2014 4k views
So I just ran "reboot now" as root on an Ubuntu 12 VM (I'd installed/updated some packages and it said reboot required). I waited a while but the machine was dead to the outside world. Not contactable via SSH or HTTP (80). I logged in via the console and: ps aux | grep nginx Yep. It's running ps aux | ssh Yep. All ok. curl -i http://www.google.com/ Nothing! Hmmm... ifconfig The interface appears to be up. /etc/init.d/networking restart Ok, but still no connectivity. Power cycled via the Droplet admin thing and everything's back to normal. Any idea what's going on there? This is a new VM with only a handful of packages installed - nothing outlandish and no config changes to do with networking at all. Any idea what's going on? Cheers, Kane
1 comment
  • @kamaln, weird?! That happens quite a bit… I’m on Ubuntu 14.04 and just did a restart and absolutely no network connections. I could log in with the console, though.

    I used init 6 to reboot, which would certainly be very close to a shutdown now.

    The procedure mentioned below worked though: init 0 and the restart from digitalocean.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

3 answers
Weird. Can you please open up a support ticket if this ever happens again? Thanks!
I'm seeing similar behavior on a similar system; want a support ticket from me too?
Oops, never mind, found another hint about a bug in "reboot now" vs. just "reboot" on the command line.

Also didn't realize my username was going to be derived from my email address like that. I'm in no way officially representing digitalocean.

Delete this at will!
Submit an Answer