Why is Postfix constantly timing out?

October 14, 2012 19.9k views
I'm having one really hard time configuring Postfix on my CentOS droplet. No matter what I do, the smtp service times out when connecting to an outside server (gmail, yahoo, etc.). I've tried following DigitalOcean's article, a howto on the CentOS wiki, and countless suggestions on various forums/message boards to no avail. I went so far as disabling iptables to see if it was a firewall issue, with no success. If anyone has successfully installed Postfix on CentOS 6, please let me know how! I've posted an example below (bear in mind "myhostname" isn't actually my hostname) Oct 14 00:30:34 myhostname postfix/smtp[3615]: connect to gmail-smtp-in.l.google.com[]:25: Connection timed out Oct 14 00:31:04 myhostname postfix/smtp[3615]: connect to alt1.gmail-smtp-in.l.google.com[]:25: Connection timed out Oct 14 00:31:34 myhostname postfix/smtp[3615]: connect to alt2.gmail-smtp-in.l.google.com[]:25: Connection timed out Oct 14 00:32:04 myhostname postfix/smtp[3615]: connect to alt3.gmail-smtp-in.l.google.com[]:25: Connection timed out Oct 14 00:32:34 myhostname postfix/smtp[3615]: connect to alt4.gmail-smtp-in.l.google.com[]:25: Connection timed out Oct 14 00:32:34 myhostname postfix/smtp[3615]: 9C4191217A7: to=, relay=none, delay=150, delays=0.03/0.02/150/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[]:25: Connection timed out)
4 Answers
We've recently had to disable port 25 on many accounts due to large amount of network abuse and spam.

It looks like you might be affected by this issue, a simple test would be:

$ telnet aspmx.l.google.com 25
Connected to aspmx.l.google.com.
Escape character is '^]'.
220 mx.google.com ESMTP l9si4881367wie.32
telnet> quit
Connection closed.

If you are not greeted with the ESMTP prompt, that means your account is restricted from port 25 traffic currently. In which case I would recommend opening a support ticket from your control panel account and we'll review and grant access on a case by case basis.


Hi ben,

I tried your command and wasn't greeted with an ESMTP prompt, so I opened a support ticket. Thank you for your help!
Just wanted to update for any current users/customers that we are not doing any port blocking, that was a temporary issue regarding trials so if you are having any issues with SMTP please open a ticket since it's something we need to investigate.

SMTP is blocked by DigitalOcean for new accounts. You must open a ticket and it will be solved instantly. It need account verification.

Have another answer? Share your knowledge.