Question

Why isn't my site showing up? (GoDaddy+DigitalOcean+Ubuntu+NGINX+Rails)

I set up my site around 2 years ago on DigitalOcean and everything has worked fine until recently. I checked it today and discovered that the homepage URL redirected to a bland “GoDaddy” page. After looking through my accounts I found that my domain expired recently and I re-upped my account and reobtained it. (I got a new debit card in the last year and forgot to update the payment details on GoDaddy.) I checked the name servers and they are redirecting to DigitalOcean. I checked all of the records on my droplet and they are all pointed correctly. (A records, MX records, etc.) My hosted email still works fine and when I upload code to GitHub for production it all works fine and my code correctly references the IP address for the droplet. All internal code files have not been changed and seem to be fine.

When I run the commands:

ping "sitename.com"

I get the correct response and it shows a reference to my droplet.

When I run:

host "sitename.com"

I get the correct reference to the droplet IP.

And when I run:

curl -IL "sitename.com"

I get the correct response.

The nameservers on GoDaddy are referenced:

Name Server: ns1.digitalocean.com
Name Server: ns2.digitalocean.com
Name Server: ns3.digitalocean.com

Everything seems to show that things should work. I see clear references to my droplet, URL, and IP address. What is going on here? Could it be that I just have to wait 24 hours or something for things to update? Please help.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello there,

You can always verify that the DNS is configured correctly using our DNS lookup tool

As mentioned the issue you’re experiencing may occur due to the browser’s or DNS cache, so you can try switching networks or using a different browser or another mobile device as well.

Regards

Hi @trevinchristian-cole,

From what I’m hearing everything is working correctly.

What I’ll recommend is to clear your browser cache or try using incognito mode to reach your website, that should be enough.

Additionally, about the 24 hours, you are correct. DNS propagation can take up to 24 hours and sometimes it does take that long.