Why isn't my site showing up? (GoDaddy+DigitalOcean+Ubuntu+NGINX+Rails)

I set up my site around 2 years ago on DigitalOcean and everything has worked fine until recently. I checked it today and discovered that the homepage URL redirected to a bland “GoDaddy” page. After looking through my accounts I found that my domain expired recently and I re-upped my account and reobtained it. (I got a new debit card in the last year and forgot to update the payment details on GoDaddy.) I checked the name servers and they are redirecting to DigitalOcean. I checked all of the records on my droplet and they are all pointed correctly. (A records, MX records, etc.) My hosted email still works fine and when I upload code to GitHub for production it all works fine and my code correctly references the IP address for the droplet. All internal code files have not been changed and seem to be fine.

When I run the commands:

ping ""

I get the correct response and it shows a reference to my droplet.

When I run:

host ""

I get the correct reference to the droplet IP.

And when I run:

curl -IL ""

I get the correct response.

The nameservers on GoDaddy are referenced:

Name Server:
Name Server:
Name Server:

Everything seems to show that things should work. I see clear references to my droplet, URL, and IP address. What is going on here? Could it be that I just have to wait 24 hours or something for things to update? Please help.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

only home page is working on my website but links are not working giving this error. can anyone help me out thi issue. "# Not Found

The requested URL was not found on this server. Apache/2.4.52 (Ubuntu) Server at Port 443"

I am facing close to this situaion I hosted my website on digitalocean and took godaddy domain now I can access my home page but none of my link on home page working give error "404 # Not Found

The requested URL was not found on this server.

Apache/2.4.52 (Ubuntu) Server at Port 443" kindly seomeone help me out this issue.

I am facing close to this issue. I am able to host my website. took hosting from and domain from now when I browse I can see my website as well I can ping my website as well. But no link on mywebsite is working Can anyone help me or guide me. Thanks regards,

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up