Why might a wordpress plugin be working on one blog but not another blog on a shared droplet

January 23, 2019 279 views
WordPress Ubuntu

I’m currently trying to get a Wordpress plugin to work on my Wordpress blog which is on a shared droplet with other Wordpress blogs. The plugin enables allowing me to configure the plugin however has server 500 issues blocking the plugins scripts and CSS from running. I have successfully tested the plugin on another Wordpress blog on the droplet where it worked fine.

I’ve raised the issue with the plugin support who have been most helpful but they are having trouble identifying the problem

Troubleshooting I’ve tried that hasn’t worked:

  • Disabling all plugins
  • Changing the theme
  • Confirming the permissions are correctly set on the plugin
  • Deleting and re-installing the plugin
  • Removing the .htaccess

Troubleshooting I’ve tried that has worked:

  • Creating a fresh Wordpress install and enabling the plugin

Can anyone see anything I’ve missed which would be worth trying?

Thanks in advance

2 Answers
unixynet January 23, 2019
Accepted Answer

Hi

There's not enough info to go on. But one more thing to check is phpinfo() on the server where the plugin is causing issues. See if perhaps there are disabled functions (disable_functions = ) that are preventing the plugin from running successfully.

Also, check the error_log file for clues if any.

Cheers

Thanks for the suggestions.

I ended up finding through the error_log there was a .htaccess file lingering in the plugin directory which was causing the issue.

Have another answer? Share your knowledge.