Question

why my nodejs app server on 9090 port with ZeroSSL but this site can't be reached ??

i made my app server apache2 + nodejs with ZeroSSL so

<VirtualHost *:80>
    ServerName domain
    ServerAlias www.domain
    DocumentRoot /home/sammy/www/site-domain
    Redirect permanent / https://domain/
</VirtualHost>
<VirtualHost *:443>
    ServerAdmin noreply@domain
    ServerName domain
    ServerAlias www.domain
    DocumentRoot /home/sammy/www/site-domain
    <Directory /home/sammy/www/site-domain>
        Options Indexes FollowSymLinks Includes ExecCGI
        #Options +FollowSymLinks
        AllowOverride All
        Order allow,deny
        allow from all
        Require all granted
    </Directory>
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
    SSLEngine on
    SSLCertificateFile /home/sammy/ssls/domain/certificate.crt
    SSLCertificateKeyFile /home/sammy/ssls/domain/private.key
    SSLCertificateChainFile /home/sammy/ssls/domain/ca_bundle.crt
</VirtualHost>
https://domain/ is working fine (on apache2 with ZeroSSL)
but 
var options = {
    // pauseOnConnect: true,
    cert: fs.readFileSync(cert_path_crt, 'utf8'),
    ca: fs.readFileSync(ca_path_crt, 'utf8'),
    key: fs.readFileSync(cert_path_key, 'utf8'),
    // requestCert: true,
    // rejectUnauthorized: false
}

https://domain:9090/ is not working problem (on nodejs with ZeroSSL) error appeared “this site can’t be reached”

(https://domain:9090/ working fine on me but cannot reached from outsite) how to fix it ?? help me, do you have any ideas to advise me !?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @noreplycmsdev,

Are you sure your NodeJS app is listening on the said port? Additionally, you need to use a reverse proxy to connect to your APP on port 9090. You can do it with Apache2 but I’ll recommend using Nginx instead.

You can check the following article on how to configure it:

https://www.digitalocean.com/community/tutorials/nginx-reverse-proxy-node-angular