Question

why my permalink is not working

why my permalink is not working except default and /index.php/%year%/%monthnum%/%day%/%postname%/

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

What worked for me, as mod_rewrite was not enabled (Fresh DO-provided wordpress app droplet as of oct.2016):

a2enmod rewrite
service apache2 restart

Same issue here, receiving a 404 unless permalinks are set as the default

/index.php/%year%/%monthnum%/%day%/%postname%/

Fresh DO-provided wordpress app droplet. Default.conf, permissions and .htaccess as suggested by Jon.

Hey there,

You’ll want to make sure your /etc/apache2/sites-available/000-default.conf has AllowOverride set to All. Also you want to make sure your /var/www/html/.htaccess file has the following permissions and contents:

CHECK PERMISSIONS:

  1. ls -lah /var/www/html/.htaccess

OUTPUT:

-rw-r--r-- 1 www-data www-data 235 Feb 12 22:27 /var/www/html/.htaccess

CHECK CONTENTS:

  1. cat /var/www/html/.htaccess

OUTPUT:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Happy coding,

Jon Schwenn Platform Support Specialist DigitalOcean