Why won't my Droplet accept my new password via SSH?

February 1, 2018 895 views
Linux Commands Ubuntu 16.04

I was having problems SSHing into my Droplet using SSH keys, so I reset my Droplet's password. I couldn't SSH in still, as it was telling me that my password was incorrect, despite it working on the online Console. So, in the console, I used passwd to change my password to something I'd know. Still doesn't work in SSH (I'm on a Mac), so I have to log in via the online console every time.

Why isn't my Droplet accepting my passwords when I SSH into it through Terminal?

I tried contacting Customer Support but after 3 days of this happening, and no response from anybody, I am questioning whether or not to even stay with DigitalOcean. This is ridiculous.

1 Answer
ryanpq MOD February 1, 2018
Accepted Answer

If you created your droplet using an ssh key it would not be configured to allow password authentication by default. To fix this you can edit your /etc/ssh/sshd_config file to ensure that PasswordAuthentication is set to yes. Then restart the ssh server with service ssh restart

Have another answer? Share your knowledge.