Question

Windows Putty with authorization keys not WORKING

Posted July 11, 2020 144 views
Networking

Hi There,

I have tried all the Tutorial about how to enable a WINDOWS Client connect with SSH after generate keys.

I could add the public key to the DROPLET using :

cat ~/.ssh/idrsa.pub | \
ssh username@203.0.113.0 “mkdir -p ~/.ssh && cat >> ~/.ssh/authorized
keys”

I could also check that the authorization key from the CLIENT MACHINE i need grant access is there after the step above

BUT …
Even with this .. Putty receives a “Server Refused our key” error message and ask me for root password.

Please I need this instructions as I CONSTANTLY need to aprove another CLIENT to access DROPLET .

Waiting for return

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello, @WilliamRails

Just to clarify this with you, at the moment you have both password and pubkey authentication enabled on your droplet? I’m asking this because you’ve mentioned that you get the error message during a password prompt.

You need to ensure that the permission of the ~/.ssh folder is 700 and 644 for the ~/.ssh/authorizedkeys

If you’ve double checked the ~/.ssh/authorizedkeys file and you can confirm that the client’s key is there, then this might be an issue with their IP being blocked.

You can examine the “`/var/log/secure”’ file and check for the client’s IP address:

grep IP /var/log/secure

You can double check the tutorial for the PuTTY connection on Windows machines here:

https://www.digitalocean.com/docs/droplets/how-to/connect-with-ssh/putty/

Hope that helps!

Regards,
Alex

Submit an Answer