WooCommerce Plugin could not be activated because it triggered a fatal error

  • Posted February 13, 2015

Having this issue after updating the woocommerce plugin today. Specifically I am getting this when I am going to activate the plugin. This is the exact error screenshot:

What I have tried:

  • Changing the WP_Memory_Limit value
  • Deleting and reinstalling WooCommerce
  • Changing the theme and trying to activate it again
  • I have turned off all other plugins to reduce likelihood of conflict
  • I have reuploaded the plugin files in case the upload/install didn’t complete correctly.

Permissions are okay for files and folders. It’s in Ubuntu VPS in DO.

But no luck! Can anyone help me in fixing this ASAP? Thanks in advance.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I have the same problem as well. Can you please point out where can we get the update to fix this problem? Any help would be appreciated.

Thanks Ryan

WooCommerce just released an update to fix this problem. It was related to the GZip. It is working now.

I am having the same problem. I already made all the changes necessary to the PHP ini file but no luck. If anyone finds a fix, please post it here.

I have installed a new wordpress in the same droplet and when I am going to install woocommerce, it’s showing the same error message. Now I am confirmed that its a server error.

Please someone help me to fix it.

Can’t find any entry for fatal error. Just got this:

[12-Feb-2015 21:39:15 UTC] PHP Notice:  Trying to get property of non-object in /var/www/ on line 11$
[12-Feb-2015 21:39:15 UTC] PHP Notice:  Trying to get property of non-object in /var/www/ on line 11$

FYI I have been trying to sort this problem here as well, but no luck:

Change WP_DEBUG to true in wp-config.php and paste the errors here.