Wordpress 3.6.1 auto-update

October 11, 2013 2.3k views
"Update WordPress Downloading update from http://wordpress.org/wordpress-3.6.1-partial-0.zip… Unpacking the update… Could not copy files. Installation Failed" I know this sounds silly, but does anyone have a simple solution to fixing this auto-update. I did the one-click auto-install wordpress 3.6, so I don't know what's the current ch-mod configuration DigitalOcean has set for me, and I don't want to mess around with it because I'm afraid I might break my site. Any assistance is much appreciated. Thank you.
6 Answers
What's the output of ls -la /your/path/to/wp-content?

What OS & webserver are you running?
I'm having the same problem.

I'm using the default permalink structure on Ubuntu 12.10.
"I'm having the same problem."

This is usually the result of permissions problems. Forego the one-click install & follow the steps outlined, here: How To Install Wordpress, Nginx, PHP, and Varnish on Ubuntu 12.04
by Etel Sverdlov
Varnish is an HTTP accelerator and a useful tool for speeding up a server, especially during a times when there is high traffic to a site. It works by redirecting visitors to static pages whenever possible and only drawing on the server itself if there is a need for an active process. This tutorial covers installing wordpress on a LEMP stack (with nginx instead of apache), and then installing varnish.
@will: Try running this command:

sudo usermod -a -G wordpress www-data
If anyone is still having the same problem as me, use the following command will fix it:

chown -R www-data:www-data /home/wordpress

I found this on another post related to auto-update on 3.6
Have another answer? Share your knowledge.