I recently installed WordPress on a LEMP stack. Everything has been working fine for the past couple of days but now the “customize” option loads to a white page and the browser tab says “Customize: Loading”. I still see the theme options on the right side of the page but the theme itself never displays.

I’ve disabled all plug-ins, uninstalled themes, cleared my browser’s cache, rebooted my droplet, and re-installed WordPress but the problem remains.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hi @tylerferguson

Can you visit the Customizer and then post the last 10 lines of your error log:

tail -10 /var/log/nginx/error.log

EDIT:
When you visit the Customizer in your browser, make sure there’s no errors relating to the Customizer displayed in your browser Console.
If you use Chrome-browser: https://developer.chrome.com/devtools

@hansen

error.log:

2017/07/27 16:41:52 [error] 17552#17552: *702 FastCGI sent in stderr: "PHP message: PHP Warning:  copy(/var/www/html/wp-admin/includes/update-core.php): failed to open stream: Permission denied in /var/www/html/wp-admin/includes/class-wp-filesystem-direct.php on line 257" while reading upstream, client: 104.57.11.106, server: hollowseason.org, request: "POST /wp-admin/update-core.php?action=do-core-reinstall HTTP/2.0", upstream: "fastcgi://unix:/run/php/php7.0-fpm.sock:", host: "hollowseason.org", referrer: "https://hollowseason.org/wp-admin/update-core.php"
2017/07/27 16:54:08 [error] 1519#1519: *27 FastCGI sent in stderr: "PHP message: PHP Warning:  copy(/var/www/html/readme.html): failed to open stream: Permission denied in /var/www/html/wp-admin/includes/class-wp-filesystem-direct.php on line 257
PHP message: PHP Warning:  copy(/var/www/html/readme.html): failed to open stream: Permission denied in /var/www/html/wp-admin/includes/class-wp-filesystem-direct.php on line 257" while reading upstream, client: 104.57.11.106, server: hollowseason.org, request: "POST /wp-admin/update-core.php?action=do-core-reinstall HTTP/2.0", upstream: "fastcgi://unix:/run/php/php7.0-fpm.sock:", host: "hollowseason.org", referrer: "https://hollowseason.org/wp-admin/update-core.php"

After taking a look in the Firefox console I got the following errors:

(JS)

Load denied by X-Frame-Options: https://hollowseason.org/?customize_changeset_uuid=0b999999-e6c3-4b68-9bc1-8972c9badab8&customize_theme=twentyfifteen&customize_messenger_channel=preview-0 does not permit framing.

(CSS)

downloadable font: rejected by sanitizer (font-family: "dashicons" style:normal weight:normal stretch:normal src index:0) source: https://hollowseason.org/wp-includes/fonts/dashicons.eot
  • @tylerferguson

    It looks like the permissions is off. If your PHP+Nginx is using the default user/group called www-data, then run the following command to reset the permissions:

    sudo chown -R www-data:www-data /var/www/html
    

    Also, it looks like you might have set the header X-Frame-Options in your Nginx configuration to something, which is too restrictive, so change it to this:

    add_header X-Frame-Options SAMEORIGIN;
    
Submit an Answer