Question

Wordpress. After give permission to /uploads folder, i can't access to options-general.php

Hi all!

First thanks for your time and sorry for my bad English.

A few days ago, i installed a wordpress site, and when i was making pages and editing my theme, in a moment i try to go to Settings / General (…/wp-admin/options-general.php) and it didn’t work, i was searching for the problem and i dont know to solve it… Now today i install a new wordpress in other folder, and advance in installation and first configuration step by step, and when i try to upload a photo… it gives me this error: …Unable to create directory wp-content/uploads/2015/02… (before trying upload photo, i can acces to Settings / General) Searching for the web i solve this giving permission to uploads folder with this command: chmod -R 777 /var/www/html/mysite/wp-content/uploads and now i can upload my photo but after this… i cant access to Settings / General, same error than my other wordpress site.

Before i execute the chmod command i can go to options-general.php, and after it, i can’t…

Does anybody knows what happend and what is my fail?

Thanks for all and for your time.

Israel.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This comment has been deleted

Are you saying you have to remove the WP SSH setup to be able to access Settings>General again?

Because I’m having the same issue. Everything in Admin is normal except I get a “no data received” page when trying to access Settings>General.

THE PROBLEM IS SOLVED!

Trying to install new wordpress, i see that the error occurs when i define ssh variables into wp-config.php to install theme and plugins, i define this variables and can install everything i want, but after this, i solve the problem removing this variables into wp-config.php, and now i can access to Settings / General (options-general.php).

I dont know why… but its real haha :) if anybody can say me why this is so, i will be grateful!

Regards!