Wordpress. After give permission to /uploads folder, i can't access to options-general.php

February 16, 2015 1.7k views

Hi all!

First thanks for your time and sorry for my bad English.

A few days ago, i installed a wordpress site, and when i was making pages and editing my theme, in a moment i try to go to Settings / General (../wp-admin/options-general.php) and it didn't work, i was searching for the problem and i dont know to solve it... Now today i install a new wordpress in other folder, and advance in installation and first configuration step by step, and when i try to upload a photo... it gives me this error: ...Unable to create directory wp-content/uploads/2015/02... (before trying upload photo, i can acces to Settings / General) Searching for the web i solve this giving permission to uploads folder with this command: chmod -R 777 /var/www/html/mysite/wp-content/uploads and now i can upload my photo but after this... i cant access to Settings / General, same error than my other wordpress site.

Before i execute the chmod command i can go to options-general.php, and after it, i can't...

Does anybody knows what happend and what is my fail?

Thanks for all and for your time.


3 Answers


Trying to install new wordpress, i see that the error occurs when i define ssh variables into wp-config.php to install theme and plugins, i define this variables and can install everything i want, but after this, i solve the problem removing this variables into wp-config.php, and now i can access to Settings / General (options-general.php).

I dont know why... but its real haha :) if anybody can say me why this is so, i will be grateful!


Are you saying you have to remove the WP SSH setup to be able to access Settings>General again?

Because I'm having the same issue. Everything in Admin is normal except I get a "no data received" page when trying to access Settings>General.

  • Yes, i don't know why, but i can access to Settings>General when i remove this lines in wp-config.php (define(); lines whit ssh setup)

Have another answer? Share your knowledge.