Wordpress and nginx on docker

Okay, so I got wordpress and nginx running on docker. Everything works fine. Except for some reason (probably me being stupid) I can’t open my site without adding the port in the url. so I want just I don’t understand. I’m getting frustrated. Please. Send. HALP.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @emanuelrahn

What you can do in order to achieve this is to set a Nginx reverse proxy. You can do this by editing the nginx configuration file:

open/create the config file /etc/nginx/sites-available/

You should have the following content:

server {
  listen 80;

  location / {
   proxy_pass http://localhost:9000;

You need to create the symlink for the file and make it available in the sites-enabled directory as well:

sudo ln -s /etc/nginx/sites-available/ /etc/nginx/sites-enabled/

Then check the Nginx configuration files for any syntax errors:

sudo nginx -t

If you see that the Syntax is Okay, then restart Nginx. If you get some syntax errors, check the exact row/line that was reported in the message and sort this out before you continue further.

sudo systemctl restart nginx

You can also see this amazing video tutorial on how to do this on a DigitalOcean droplet:

Hope this helps!

Regards, Alex