Wordpress asking for FTP info to install theme, but I have ssl passphrase.

August 3, 2013 14.7k views
I installed Wordpress on my droplet, and I want to install another theme and some plugins, but Wordpress is asking for FTP credentials. But I am using vsftpd and ssl to login with passphrase. So what should I specify for the hostname? Should this be the ip address, or should it be mysite.com? If I am using vsftpd and ssl with passphrase, what should I provide for the username and password? Wordpress seems very difficult to setup on a droplet, but maybe its just me. Thanks in advance.
19 Answers
Add this to wp-config.php:


Try installing the theme again, does that fix it?
Run these commands:

chgrp -R www-data /srv/www/wp-content
chmod -R g+w /srv/www/wp-content
That got me past the ftp login screen, but then I got a message "Could not create directory":

Installing Theme: Responsive

Downloading install package from http://wordpress.org/themes/download/responsive.…

Unpacking the package…

Could not create directory. /srv/www/wp-content/mysite.com/upgrade
As opposed to trying to install the theme through the WordPress interface, another option is download & unzip the theme through the command line.
I tried that but no luck. I'm wondering about the path. This seems wrong:


The files are actually here:


and a symbolic link points here:


Do I modify some file to correct a file path issue?
Oh. I didn't know that.

Run these commands then:

chgrp -R www-data /usr/share/wordpress/wp-content
chmod -R g+w /usr/share/wordpress/wp-content

(Are you sure that's the correct path?)
Yeah. Ran those commands. I can even manually upload the theme zip. Its never recognized in the WP admin UI, just never shows up. Don't know why WP is confused about the path.
Weird. Why are your paths set up like that? Did you follow an article on installing Wordpress? If so, can you please link it?
@greglafrance007, did you install WordPress via the OS's repository? If so, you should think twice about that b/c the WP release available is much older (so you'll miss out on a lot of big-fixes).
Yeah. I spoke with a friend and he said just copy the files where I want them and do the 5 minute install. I'll try that, but thanks for your help.
by Etel Sverdlov
Wordpress is a free and open source website and blogging tool that uses php and MySQL. It was created in 2003 and has since then expanded to manage 22% of all the new websites created and has over 20,000 plugins to customize its functionality. This tutorial shows how to install Wordpress on a server with LEMP (with nginx instead of apache). It is written for Ubuntu 12.04.
Facing same issue. now after reading this I solved this.

But now I cant update the wordpress.

Getting this error:

Update WordPress

Downloading update from http://wordpress.org/wordpress-3.6.1-new-bundled.zip…

Unpacking the update…

Could not copy files.

Installation Failed
@tusharthakur123: How did you install Wordpress?
A little late to the game, but just chmod your upload folder to 777

Thanks Kamal, that's exactly what I needed, and is a bit safer than setting the whole Wordpress install dir to 777.

sudo adduser <username> www-data
sudo chown -R www-data:www-data /var/www
sudo chmod -R g+rw /var/www

its worked for me

Ok, After reading some article,I think I find the right way to solve this problem.
Add this to wp-config.php: define('FS_METHOD','direct');
Don't use any order, you should change the permission of /yourwww/wp-content and /yourwww/wp-content/plugins to 777. Of course ,the /yourwww/wp-content and the /yourwww/wp-content/plugins should have the 777 permission. The problem is about permission. After you do this,you will never face this problem again.

This is user's permission problem that will be solved by method given below that worked for me.

step-1 : First open wp-config.php file of your wordpress installation folder.
step-2: Copy below code and paste it at the end of the wp-config.php file.


step-3: Now open your droplet access console and enter root as username and its password.
step-4: Copy below code and paste it into access console where you have to specify your plugin directory path and then hit enter.

chmod 777 /yourwebsitename/public/wp-content/plugins/

Note: Replace your website name in the place of yourwebsitename.
Thank you.

Have another answer? Share your knowledge.