Question

Wordpress asking for FTP info to install theme, but I have ssl passphrase.

Posted August 3, 2013 48.8k views
I installed Wordpress on my droplet, and I want to install another theme and some plugins, but Wordpress is asking for FTP credentials. But I am using vsftpd and ssl to login with passphrase. So what should I specify for the hostname? Should this be the ip address, or should it be mysite.com? If I am using vsftpd and ssl with passphrase, what should I provide for the username and password? Wordpress seems very difficult to setup on a droplet, but maybe its just me. Thanks in advance.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
21 answers
Add this to wp-config.php:

define('FS_METHOD','direct');

Try installing the theme again, does that fix it?
That got me past the ftp login screen, but then I got a message "Could not create directory":

Installing Theme: Responsive 1.9.3.5

Downloading install package from http://wordpress.org/themes/download/responsive.1.9.3.5.zip…

Unpacking the package…

Could not create directory. /srv/www/wp-content/mysite.com/upgrade
Run these commands:

chgrp -R www-data /srv/www/wp-content
chmod -R g+w /srv/www/wp-content
I tried that but no luck. I'm wondering about the path. This seems wrong:

/srv/www/wp-content/mysite.com/upgrade

The files are actually here:

/usr/share/wordpress/wp-content

and a symbolic link points here:

/var/www/mysite.com/wp-content

Do I modify some file to correct a file path issue?

Ok, After reading some article,I think I find the right way to solve this problem.
First
Add this to wp-config.php: define(‘FS_METHOD’,'direct’);
Two
Don’t use any order, you should change the permission of /yourwww/wp-content and /yourwww/wp-content/plugins to 777. Of course ,the /yourwww/wp-content and the /yourwww/wp-content/plugins should have the 777 permission. The problem is about permission. After you do this,you will never face this problem again.

As opposed to trying to install the theme through the WordPress interface, another option is download & unzip the theme through the command line.
Oh. I didn't know that.

Run these commands then:

chgrp -R www-data /usr/share/wordpress/wp-content
chmod -R g+w /usr/share/wordpress/wp-content

(Are you sure that's the correct path?)
Yeah. Ran those commands. I can even manually upload the theme zip. Its never recognized in the WP admin UI, just never shows up. Don't know why WP is confused about the path.
Weird. Why are your paths set up like that? Did you follow an article on installing Wordpress? If so, can you please link it?
@greglafrance007, did you install WordPress via the OS's repository? If so, you should think twice about that b/c the WP release available is much older (so you'll miss out on a lot of big-fixes).
Previous 1 2 3 Next