Hi,

I had a fully functioning wordpress droplet, after transferring the droplet to another account and deleting the site from the first, I replaced the old droplet ip with the new one in the database using the wp-cli tool.

The homepage openned but the wp-admin page broke saying there’s a critical error, and now even the homepage won’t show.

I tried disabling the plugins and themes and turning on debugging mode but there are no errors in the apache access, apache error, or debug logs.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @Shalashtein,

Can you share the exact critical error that you are seeing?

Also have you checked your database to make sure that the search and replace went through correctly?

Regards,
Bobby

  • That’s the thing, no errors are being logged. I just see “There has been a critical error on this website. Please check your site admin email inbox for instructions.” without even an email.

    I have double-checked the database as well.

    Thanks

    • Hi there,

      What I could suggest in this case is to add the following PHP Debugging snippet in the begining of your wp-config.php file:

      // Debugging
      ini_set('error_reporting', E_ERROR);
      register_shutdown_function("fatal_handler");
      function fatal_handler() {
          $error = error_get_last();
          echo("");
          print_r($error);
      }
      

      Feel free to share the errors here.

      Regards,
      Bobby

Submit an Answer