WordPress Display FTP Credentials and FileZilla Cannot Retrieve Directories

January 10, 2018 1.4k views
Apache WordPress Configuration Management Control Panels Let's Encrypt Ubuntu 16.04

Hi There!

I installed my system like you explain in your documentation and this is my system.

  • Ubuntu 16.04
  • Using SSL through LetsEncrypt module
  • ProFTPD module Main
  • Main Domain is a WordPress

I know there’re a lot subjects for this issue and I read dozens of documentations but unfortunately nothing of those solutions working with me, I installed virtualmin correctly (I think) I’ll write the commands that I run to make sure it’s ok setup

Install Commands

  1. sudo apt-get update
  2. sudo apt-get dist-upgrade -y
  3. This message A new version of /boot/grub/menu.lst is available but the version installed currently has been locally modified appeared ONCE during setup and I chose Install the package maintainer’s version
  4. Reboot the system
  5. wget https://software.virtualmin.com/gpl/scripts/install.sh -O /root/virtualmin-install.sh

Then I create the first virtual server for my main domain and sub domains and request LetsEncrypt certificates and all working very well.

My Issue with FTP, WordPress and FileZilla

1- I tried to login in FileZilla with Host: ftp@DOMAIN_NAME.com but I received the following messages…

    Status: Initializing TLS...
    Status: Verifying certificate...
    Status: TLS connection established.
    Status: Logged in
    Status: Retrieving directory listing...
    Status: Server sent passive reply with unroutable address. Using server address instead.
    Command:    MLSD
    Error:  Connection timed out after 20 seconds of inactivity
    Error:  Failed to retrieve directory listing

2- In my main domain I cannot add new plugin or media file and FTP credentials box appear too (I think it’s related).

My solutions after some search

1- I made some searches and I see this command {modprobe ipconntrackftp} in {https://www.virtualmin.com/documentation/web/faq#toc-ftp-service-isnt-working-Llnjz8K8} so I make the following steps Then I Reboot the system.

  • sudo modprobe ipconntrackftp
  • Add the line {ipconntrackftp} to {/etc/modules}
  • sudo reboot

2- I made some changes to {/etc/proftpd/proftpd.conf} Then Restart the ProFTPD service .. These are my new settings

UseIPv6                          off
ServerName                   "mydomain.com"
DefaultRoot                    ~
RequiredValidShell        on
AuthOrder                      mod_auth_pam.c* mod_auth_unix.c

3- I read about IP Tables but I don’t know Is that what I need?

– The Result .. Nothing Changed the same message appear in FileZilla and I cannot add or upload plugin and media in my WordPress website.

Thanks for your help.

Be the first one to answer this question.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!