alopez
By:
alopez

Wordpress droplet randomly stopped working this morning. Returning 500. Any thoughts?

May 22, 2015 1.5k views
Apache WordPress Ubuntu

We have a word press droplet that we've been using as a blog. It's worked fine until this morning when I was informed it wasn't working. Going to the site returns a 500 whether I go through the domain name or the IP address. I checked the apache error log file and it seems normal.

[Sun May 17 06:53:58.314794 2015] [mpm_prefork:notice] [pid 1659] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.4 configured -- resuming normal operations
[Sun May 17 06:53:58.315263 2015] [core:notice] [pid 1659] AH00094: Command line: '/usr/sbin/apache2'
[Fri May 22 15:32:23.031961 2015] [mpm_prefork:notice] [pid 1064] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.4 configured -- resuming normal operations
[Fri May 22 15:32:23.032690 2015] [core:notice] [pid 1064] AH00094: Command line: '/usr/sbin/apache2'
[Fri May 22 15:46:37.572139 2015] [mpm_prefork:notice] [pid 1064] AH00169: caught SIGTERM, shutting down
[Fri May 22 15:46:38.665183 2015] [mpm_prefork:notice] [pid 1529] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.4 configured -- resuming normal operations
[Fri May 22 15:46:38.665262 2015] [core:notice] [pid 1529] AH00094: Command line: '/usr/sbin/apache2'
[Fri May 22 15:47:32.685637 2015] [mpm_prefork:notice] [pid 1529] AH00169: caught SIGTERM, shutting down
[Fri May 22 15:48:10.069802 2015] [mpm_prefork:notice] [pid 1098] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.4 configured -- resuming normal operations
[Fri May 22 15:48:10.070646 2015] [core:notice] [pid 1098] AH00094: Command line: '/usr/sbin/apache2'
[Fri May 22 15:55:37.539698 2015] [mpm_prefork:notice] [pid 1098] AH00169: caught SIGTERM, shutting down
[Fri May 22 15:55:46.988588 2015] [mpm_prefork:notice] [pid 1100] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.4 configured -- resuming normal operations
[Fri May 22 15:55:46.989450 2015] [core:notice] [pid 1100] AH00094: Command line: '/usr/sbin/apache2'

I checked /var/www and all the WP files still seem to be there. I even restored a three day old backup and this is still happening. I know this happened around 10AM because at that time our CPU graph and Bandwidth graph both flatlined. About 20 minutes prior there was a spike in the Disk graph.

Any thoughts?

1 Answer

I am no expert so you better wait for the expert to comment in but it seems for some reason MySQL may have run out of RAM.

If you dont have swap, add a 512 MB swap and restart the services, including MySQL and apache.. If you have a large swap, you may want to reduce it to 512MB and add more RAM in that case..

Also, do you have any caching plug in running ??

Add one caching plug in, as that helps to reduce load.

Have another answer? Share your knowledge.