Wordpress Facebook login button not loading

July 15, 2014 2.2k views

Hi I am getting this error message on Wordpress facebook login button, they are running on Ubuntu.

I have already checked with theme provider and checked all the configuration are correct.

Please could you advise what might be the issue.

Failed to load resource:
        the server responded with a status of 500 (Internal Server

POST http://www.xxxxxxxxx.com.mm/wp-admin/admin-ajax.php
        500 (Internal Server Error) 

      Details of the error:

Remote Address:  128.199.180.xxx:80
Request URL:  http://www.xxxxx.com.mm/wp-admin/admin-ajax.php
Request Method:  POST
Status Code:  500 Internal Server
Request Headersview source
Accept:  */*
Accept-Encoding:  gzip,deflate,sdch
Accept-Language:  en-US,en;q=0.8,nl;q=0.6,ro;q=0.4,es;q=0.2,it;q=0.2,ru;q=0.2
Connection:  keep-alive
Content-Length:  55
Content-Type:  application/x-www-form-urlencoded;
Cookie:  wordpress_4c37716057a1ac67a1724c4b5a846374=contact%40xxxxxx.com.mm%7C1405587466%7C895bfc4def5a2f6ee78ee46a80ff2824;

User-Agent:  Mozilla/5.0
              (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like
              Gecko) Chrome/35.0.1916.153 Safari/537.36
X-Requested-With:  XMLHttpRequest
Form Dataview sourceview URL encoded
action:  wpestate_ajax_facebook_login
login_type:  facebook
Response Headersview source
Access-Control-Allow-Credentials:  true
Access-Control-Allow-Origin:  http://www.urldeleted.com
Cache-Control:  no-cache,
              must-revalidate, max-age=0
Connection:  close
Content-Length:  0
Content-Type:  text/html;
Date:  Tue, 15 Jul 2014
              09:00:17 GMT
Expires:  Wed, 11 Jan 1984
              05:00:00 GMT
Pragma:  no-cache
Server:  Apache
X-Content-Type-Options:  nosniff
X-Frame-Options:  SAMEORIGIN
X-Powered-By:  PHP/5.5.9-1ubuntu4
X-Robots-Tag:  noindex
1 comment
  • Hi! What is the name of the plugin you are using? Are you seeing any errors in your Apache logs? Try to use the Facebook login and after the it errors, run tail /var/log/apache2/error.log

5 Answers

Did you try restarting the apache2 webserver?

sudo service apache2 restart


there is no plug in, in theme there is already a function for facebook, google login.

I just need to provide secret and api.

I have already tried to restart server as well, it didn't resolve.

Also I remember I updated some file to increase upload limit of wordpress from 2M to higher.
I am not sure that might cause an issue.

following are the logs from /var/log/apache2/error.log.

[Sat Jul 12 14:10:16.221502 2014] [core:notice] [pid 1097] AH00094: Command line: '/usr/sbin/apache2'
[Mon Jul 14 10:56:31.321155 2014] [mpm_prefork:notice] [pid 1097] AH00169: caught SIGTERM, shutting down
[Mon Jul 14 10:56:32.361608 2014] [mpm_prefork:notice] [pid 10361] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4 configured -- resuming normal operations
[Mon Jul 14 10:56:32.361717 2014] [core:notice] [pid 10361] AH00094: Command line: '/usr/sbin/apache2'
[Tue Jul 15 05:28:20.895228 2014] [mpm_prefork:notice] [pid 10361] AH00169: caught SIGTERM, shutting down
[Tue Jul 15 05:28:29.832446 2014] [mpm_prefork:notice] [pid 1100] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4 configured -- resuming normal operations
[Tue Jul 15 05:28:29.833252 2014] [core:notice] [pid 1100] AH00094: Command line: '/usr/sbin/apache2'
[Tue Jul 15 22:46:19.944383 2014] [mpm_prefork:notice] [pid 1100] AH00169: caught SIGTERM, shutting down
[Tue Jul 15 22:46:20.983693 2014] [mpm_prefork:notice] [pid 8284] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4 configured -- resuming normal operations
[Tue Jul 15 22:46:20.983819 2014] [core:notice] [pid 8284] AH00094: Command line: '/usr/sbin/apache2'

Thank you.

Hi I have just tried to install facebook login plugin, after that, website is not even come up any more :).. I don't have snap backup yet, so please could you also advise how can I roll back. I still have access to server cli.


Hi, Thanks for the answers. It's getting resolved by a friend who help me to login to server and fixed it. facebook login button was not working because it's require some kind of plugin.

I appreciate all your respond.

have a nice day :)

Hi sailwinthu,
I've tried to implement a facebook login with both JS + PHP server side by using an AJAX Post. Although, I'm getting the same error. How did you solve it?

Cheers :)

Have another answer? Share your knowledge.