Wordpress Home Page Not Loading After Theme Install

October 14, 2014 4.6k views
noodles
By:
noodles

After installing WordPress on my droplet, activating the required plugins, installing my theme and uploading some demo content, the home page stopped loading.

I went through the following steps:

  1. Created a droplet and installed WordPress on Ubuntu 14.04 using the one-click installer
  2. Use SSH to login to my droplet & obtain the htaccess login details
  3. Setup Wordpress
  4. Used the terminal to increase the max file size upload from 2MB to 20MB
  5. Installed my theme
  6. Installed & activated the all of the required plugins
  7. Uploaded the demo contet provided with the theme
  8. Selected the 'Static Page' option in Settings > Reading as specified by the theme documentation.

After refreshing the page, all that is shown is the spinning activity indicator. The theme does not load as it should.

I went through the same steps on my localhost (MAMP) and another hosted server (Dreamhost) and no problems at all.

I suspect it's a PHP or an Apache setting.

Can anybody help?

2 comments
  • "I suspect it's a PHP or an Apache setting..."

    maybe, but check a couple of things first:

    Your home page is not loading, but can you login?
    IF you can login to WordPress, what are your permalink settings? (Settings>Permalinks)
    try clicking the "save" button on permalinks twice.
    on the bottom of the permalinks setting page, does it give any messages about your .htaccess file?

    Also, from a command prompt, run: sudo chown -R www-data:www-data /var/www
    this will give permissions to apache for any files that might have other permissions.

    after each of those steps, clear your browser cache and reload your home-page by holding down shift while reloading.

    If none of those things work, then you might start dinkering with Apache (check error logs from command-prompt like so: sudo tail -f /var/log/apache2/error.log

    that might give you some indication of what is happening.

  • The best thing to do would be to define WP_DEBUG = true in your wp-config.php file, and view the errors on the front-end.

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', true );
    

    If the errors are WordPress related, those errors will be visible when you reload the home page.

2 Answers

Thanks for your suggestions. I tried all of them.

  • Updated permalinks twice
  • Ran sudo chown -R www-data:www-data /var/www & restarted apache
  • Checked the log files - no errors

After I set WP_DEBUG to true, the following notices were displayed before the page tries to load the header:

Notice: Undefined index: custom_css in /var/www/wp-content/themes/eventme/header.php on line 82

Notice: Undefined index: custom_css in /var/www/wp-content/themes/eventme/header.php on line 88

The theme is trying to load a large header but instead just shows a spinning activity indicator:

178.62.252.130

Here is the link to the theme I am trying to install:

http://themeforest.net/item/eventme-responsive-event-landing-page/7437582

It seems like something is preventing the images from loading. As I mentioned before, the exact same setup works on other servers.

Any more ideas?

Thanks. Nigha that helped me. cherrs

Have another answer? Share your knowledge.