Question

Wordpress Links only allow Plain permalinks

When I try to change my permalink settings from Plain to any of the other options, all pages but the homepage then say that the page is not found. I have already tried deleting the .htaccess file so that it re-generates.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hello,

What you would need to check is the following.

  • Make sure that Apache mod_rewrite is enabled, you can check that with this command:
apachectl -M | grep -i rewrite
  • If you don’t see the module, you can enable it with this command:
sudo a2enmod rewrite

Restart apache after running this command

  • Make sure that AllowOverride is enabled for your htaccess file. In your Apache Vhost for the site in question (should be something like this: sudo nano /etc/apache2/sites-available/mysite.conf) make sure that you have the following somewjere after the ServerName line:
    <Directory /var/www/mysite>
        AllowOverride All
    </Directory>

Hope that this helps! Regards, Bobby

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.