Question

Wordpress marketplace css cache

I want to make changes to my website from the server, but the css changes I make are not reflected on the site, I’m loading the script with random version number and it still doesn’t work

wp_enqueue_style( 'main-style', get_template_directory_uri() . '/assets/css/main.css', array(), filemtime(get_template_directory(). '/main.css') , 'all' );

Could it be some kind of server cache? If so, how can I disable it?

I am using the installation of the digital ocean market place of worpdress


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @emileie

Whenever this happens you can try to load the style.css file in your browser in order to prevent issues with loading the css from the cache, e.g access yourdomain.com/style.css in the browser and this should fix the issue for you.

Hope that this helps! Regards, Alex

Hello @emileie ,

Have you tried the following:

  • Visiting the page from the incognite window.
  • Minify is enabled? Try to delete your cache folder from wp-content folder.

Do you work with cache system?

Cheers, Sergio Turpín